Reply To: Ionic Serve Problem!

#40784

Scott Lang
Keymaster
Hi, As per the error details which you have shared with us we have figured out that It is an issue of the ionic setup, not code issue which we have used in our App. You have not installed the firebase module. Run this command: npm i firebase to root of your project. Also we have build our apk with node -v : v8.10.0 . AND ionic info : Ionic: Ionic CLI : 5.4.4 (C:\Users\99fus\AppData\Roaming\npm\node_modules\ionic)
Ionic Framework : ionic-angular 3.9.5
@ionic/app-scripts : 3.2.2Cordova: Cordova CLI : 9.0.0 ([email protected])
Cordova Platforms : android 8.1.0
Cordova Plugins : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 4.1.2, (and 18 other plugins)Utility: cordova-res : not installed
native-run : 0.2.8 (update available: 0.2.9)System: NodeJS : v8.10.0 (C:\Users\99fus\AppData\Roaming\npm\node_modules\node\bin\node.exe)
npm : 6.11.3
OS : Windows 10
Copyright VibeThemes.