Android app unable to login

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #55716

    Vick
    Participant

    Hi. I’ve built the android app successfully and it is showing all the courses and basically everything that is on the web. I can view the course and curriculum. But I am unable to login as a student or as administrator. I saved the password and when I try to login using the saved user I noticed that under the username it is showing https://localhost. Where you a this localhost coming from and is this the reason it is not able to login? Please help and let me know how to fix this login issue.

    #55726

    Vick
    Participant
    This reply has been marked as private.
    #55727

    Vick
    Participant
    This reply has been marked as private.
    #55930

    Harry
    Keymaster

    Hello

    Add this code in your .htaccess file
    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0

    IF above does not works then please change the above line to :

    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1

    The .htaccess file will be present in your WordPress core folder.

    After adding this code, The login issue will be resolved.

     

    #55931

    Vick
    Participant

    Hello. I am hosting on Windows Server / IIS. I tried this solution already from one of your old posts. But this didn’t do the trick. I am still getting the same error. Can you suggest anything else for Web.Config file in windows server.

    #55992

    WPLMS
    Keymaster

    The issue is that Authorisation header is being stripped out. This is something related to your server settings.
    Following links are helpful to find a solution :

    https://stackoverflow.com/questions/26475885/authorization-header-missing-in-php-post-request
    https://stackoverflow.com/questions/19550632/http-authorization-headers-being-removed

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.