WordPress LMS for Web and mobile Forums Ionic App Support App not working when used wp-hide plugin

App not working when used wp-hide plugin

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #29152

    Pulkit Poddar
    Participant
    Hi, I have used a plugin named "WP-Hide" which helps in hiding the WordPress website and makes it secure. But using this plugin I am not able to use the app, whereas I am able to use the website is working just fine. Please help. I am sharing the credentials in the other message.
    #29153

    Pulkit Poddar
    Participant
    This reply has been marked as private.
    #29154

    Alex
    Keymaster
    Well im sorry I could not login : http://prntscr.com/of3ctv please share the login url .
    #29155

    Pulkit Poddar
    Participant
    This reply has been marked as private.
    #29157

    Harry
    Spectator
    Hey Pulkit website maintainence page is blocking all requests even the /wp-json hit http://prntscr.com/of3kou on which our api is written please contact the wp-hide plugin author or support to exclude atleast some requests /wp-json. If you want to see then login your site on other pc or in incognito mode.
    #29158

    Pulkit Poddar
    Participant
    Hi Alex, I have revoked the setting, can you please check again. Once site is open just login like a normal user and then visit dashboard once logged in.
    #29160

    Harry
    Spectator
    Hey Site url is working but wp-json is not working where all api will be shown through that : http://prntscr.com/of46zi so please contact wp-hide plugin author and support and allow access to wp-json for wordpress api.
    #29161

    Pulkit Poddar
    Participant
    Hi, Please try this URL. https://maxplore.website/api/
    #29177

    Harry
    Spectator
    Hey In your app code open the src folder then go to config.ts file and change this code to this.baseUrl = this.settings.url+'wp-json/wplms/v1/'; change the wp-json into api this.baseUrl = this.settings.url+'api/wplms/v1/';
    #29180

    Pulkit Poddar
    Participant
    Hi Harry, I am using App Version 3 in the API Setting. Do you still want to change the link to this.baseUrl = this.settings.url+’api/wplms/v1/’; instead of this this.baseUrl = this.settings.url+’api/wplms/v3/’;
    #29225

    Harry
    Spectator
    Yes change the setting to this.baseUrl = this.settings.url+’api/wplms/v1/ No Matter which version you use the api See the api will be shown data through this :http://prntscr.com/ofm25f
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.