WordPress LMS for Web and mobile Forums WPLMS Student App `Cannot read property 'social' of null` in Instructors Menu

`Cannot read property 'social' of null` in Instructors Menu

Back to course
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5981

    fab433
    Participant

    Hi

    when test app with ionic serve

    I haveCannot read property 'social' of null in Instructors Menu

    any ideas ?

    Regards

    #5985

    fab433
    Participant

    if i delete social part in instructor.html i have same issue but with bio

    Cannot read property 'bio' of null

    so seems issues here

    #6000

    Alex
    Keymaster

    Well these error can appear when you have not set any “Instructor description field ” in your wp-admin -> wplms -> buddypress-> “Instructor Description Field” .(field name is case sensitive ) .this is the field where instructor use to put info about themselves.

     

    Second error for social is coming because you have not set any social field group and state it there in wplms-> buddypress -> social profile field group .
    Please create a social profile field group there .

    refer : https://wplms.io/support/knowledge-base/social-profile-field-group/

     

    #9831

    Sandi
    Participant

    Hi

    I’m getting the same errors and I have set the fields. Is it possible there’s something else that I have to set?

    #9833

    Alex
    Keymaster

    Well im not being able to replicate the issue .Please make sure that you are using latest app code (download latest from codecanyon ) .

    If already using latest then please create your own topci and then share your site url and admin credentials there in private reply to check this issue.

    #9839

    Sandi
    Participant

    Interesting, I’m getting some mixed results. When I test a build on my phone I don’t get errors and on the “instructors” page I get the bio displayed but still get “false” for the “instructor speciality”. I also don’t see any social links.

    Then if I go under course -> instructor, I see all the data.

    There’s also some differences if I’m logged in or logged out. Just can’t figoure it out…

    #9866

    Alex
    Keymaster

    Well yes it displays false if instructor does not add anything to  specialty field in her profile .
    For the mixed results issue please try clearing uninstalling the app in your phone and install it again .
    In browser please try clearing the application data .
    refer : 
    http://prntscr.com/iouaw1

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.