WordPress LMS for Web and mobile Forums Ionic App Support Completely wrong tutorial and course for setting the app (latest ionic5-2.7)

Completely wrong tutorial and course for setting the app (latest ionic5-2.7)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40482

    Pero
    Participant

    I’am a 15+ years web developer and i’m fighting with both your web theme and app.

    None of the available courses and tutorials explaining how to install, develop and use the app are usable at all.

    First you have to divide them into at least two branches: One for the old 2/3 ionic and second one for the latest 2.5-2.7 4/5 Ionic version.

    Commands, print screens, dependencies are all different than yours in the tutorials. Its a shame that we can do a lot more and achieve installation without your trial and error receipts by using third party generic Ionic tutorials.

    Installation – not usable
    dependencies – not usable
    web/app settings – not usable
    firebase tutorial – not usable

    I had the app working with previous versions, based on previous version of Ionic.
    The new version cant be produced that way and i’m struggling to even start it.

    Your explanation for every problem “Give me your site credentials and we will work it out” is unacceptable, because i cannot ask you that in 03 in the morning when i have a problem.

    It should have been working, by the tutorial and course in the first place. I cannot depend on you connecting to my site every now and then anything is change.
    I need the app working 24×7 whatever and whenever i need to change anything.

    PLEASE for the sake of all your current and future customers, do this whenever you develop a new version and put it in a separate course for every version:

    Install a blank Windows 7/10.
    Start recording:
    1. Install node.js
    2. install Ionic cordova
    3. Set the project
    4. Set the dependencies
    5. Set the app id and all the other settings at the ionic app
    6. Test it internally
    7. Install new Firebase/wallet/other external dependencies
    8. Build the app
    9 Change Logo, Splash screens, Interface text and all that is indeed basic functionality of the app in Android Studio.

    10. Make a separate tutorial how to sign the app and prepare it for Google play.

    11. It goes without saying: DO THIS ONCE AGAIN ON MAC COMPUTER AND APPLE STORE

    Thanks for your reading, your precious time, your communication and your express changing of at least the worst and totally wrong tutorial on the web from the beginning of its existence:
    https://wplms.io/course/getting-started-with-wplms-mobile-app/setting-up-ionic-project/

    Regards,
    pissed-off customer

    #40483

    WPLMS
    Keymaster

    Pleae chekc this link on how to start steip by step :
    https://gist.github.com/MrVibe/3beb7c429d34eb55f0bc64c4ddbda816

    #40490

    Ahmed Reza
    Participant

    OMG, this was so desperately needed! I wasted so many hours trying to figure out heads or tails of this thing. I’ll try it out and report back on if it’s working

    #40510

    Pero
    Participant

    Checked the whole procedure and it is finishing allwright but with the same problems in working with the app.

    Here is general information about the problems:

    My site specifics:
    One instructor (so checked remove instructors from LMS settings)
    All courses free
    only 6 courses
    Enabled Levels but not showing/cannot filter

    Problems and Crashes:

    1. MENU: Instructors (i have selected in LMS settings not to show instructors, because i have only one, the owner, in config.ts i have ‘instructors’: 0 and deleted from menu Instructors, but still, its there) – Crashes

    2. MENU: Directory
    FILTER OPTIONS: Doesn’t load LEVELS and Select Level empty (in config.ts i have levels:1)
    Sort options: Highest Rated and Upcoming – crash
    Search course by name not working – crash

    3. HOME: Crash
    core.js:1449 ERROR SyntaxError: Unexpected end of JSON input
    at JSON.parse (<anonymous>)
    at Response.Body.json (http.js:1091)
    at MapSubscriber.project (course.ts:421)
    at MapSubscriber._next (map.js:79)
    at MapSubscriber.Subscriber.next (Subscriber.js:93)
    at XMLHttpRequest.onLoad (http.js:1591)
    at t.invokeTask (polyfills.js:3)
    at Object.onInvokeTask (core.js:4751)
    at t.invokeTask (polyfills.js:3)
    at r.runTask (polyfills.js:3)

    4. Sign in with already made account on the WP: Error in console
    Failed to load resource: the server responded with a status of 401 (Unauthorized)
    /wp-json/wplms/v1/user/signin
    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

    5. Signup with new name/email/pass:
    /wp-json/wplms/v1/user/register 401 Unathorized
    {“code”:”rest_no_route”,”message”:”No route was found matching the URL and request method”,”data”:{“status”:404}}

    I cannot test any of the courses, because i cant sign in
    Please reply with solutions for this scenarios. As i once stated, i cannot accept that you change remotely on the WP and/or the app, because you are not working for me and this has to be working on every situation on every test site/app that we are working on and then maybe at the end on the final version (for the final version we will pay all the customization that you want to keep it working, but in this phase (testing) it has to work all the time…

    Still has some hope…
    customer

    #40586

    Pero
    Participant

    After your intervention to make your application work:
    PLEASE URGENTLY – i Need  the IONIC and ANDROID project folders, so i can finish my translation, logo and other changes.

    I don’t need your ready APK with your company Splash Screen, Logo and info

    #40970

    Scott Lang
    Keymaster

    Hi,

    Is Your registration or login working? If not please clear app cache and check console_log and network if any error occurs.

    Also, rest_no_route means you have not configured config.ts file properly. It can be URL or client id

    Have you done this setting in your site : http://prntscr.com/qbdbr2 .  ?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.