WordPress LMS for Web and mobile Forums Ionic App Support Free button and Profile not working due to 401 (Unauthorized)

Free button and Profile not working due to 401 (Unauthorized)

Viewing 30 posts - 1 through 30 (of 35 total)
  • Author
    Posts
  • #9685

    pixitale
    Participant
    Response {_body: "{"code":"rest_forbidden","message":"Sorry, you are not allowed to do that.","data":{"status":401}}", status: 401, ok: false, statusText: "Unauthorized", headers: Headers, …}   https://drive.google.com/open?id=1uPXOkd6zSXEKvCr2SarcRMminW6dftnf https://drive.google.com/open?id=1917YfJGiUy7UaxsPGV8GoRzmsbqGg400
    #9770

    admin
    Member
    Apologies for the delay in response . This is very common error ,simply make sure that your vibe course module and vibe customtypes plugin are updated to latest version 3.4.1 . Secondly please add this line at the end in your .htaccess file that you will in root of your site (where wp-content folder is ) . SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0
    #19611

    Shagun Kaushik
    Participant
    I'm still unable to solve this. I've added the line and both plugins are updated by version 3.9
    #19645

    admin
    Member
    please share your site url , admin credentials and valid ftp credentials  in private reply to check this issue at your end .
    #19764

    Shagun Kaushik
    Participant
    This reply has been marked as private.
    #19879

    Scott Lang
    Keymaster
    Also put this line in your .htaccess file at the end (.htaccess can be found in root of your site ): SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0 IF above does not works then please change the above line to : SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1   also make sure storage cache is cleared.
    #19915

    srinivas
    Participant
    This reply has been marked as private.
    #19916

    srinivas
    Participant
    I set this in .htaccess SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0 does not work SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1 does not work
    #19918

    srinivas
    Participant
    This reply has been marked as private.
    #19945

    srinivas
    Participant
    HI Team, Can you please help me to solve the issue for registration and login. URL: https://example.com/awscourse/wp-json/wplms/v1/user/signin Req : { "username": "nidadavolu", "password": "test12345", "client_id": "K5FANN3wnfQQrrK4XjtihjItP", "state": "", "device": "69620E9B-2C05544-82E6-B1D9AE03B720", "platform": "iOS", "model": "x86_64" } Response: { "code": "rest_forbidden", "message": "Sorry, you are not allowed to do that.", "data": { "status": 401 } } I have already shared my ftp details
    #20026

    Scott Lang
    Keymaster
    Hi, you have to set those above code like : http://prntscr.com/mkicqj
    #20028

    Scott Lang
    Keymaster
    After this if issue not solved then provide us your site url , username, password in private reply. we will check to configure your app to our end.
    #20225

    srinivas
    Participant
    still same issue </IfModule> # END WordPress SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$0 SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1 not solved. can you please check through ftp and solve
    #20226

    srinivas
    Participant
    This reply has been marked as private.
    #20247

    admin
    Member
    This reply has been marked as private.
    #20464

    srinivas
    Participant
    This reply has been marked as private.
    #20503

    tatorosas
    Participant
    <span style="color: #17394d; font-family: 'Helvetica Neue', Arial, Helvetica, sans-serif; font-size: 14px; background-color: #ebeef0;">No funciona el registro de usuarios a curso estos no se cargan</span>
    #20710

    Shagun Kaushik
    Participant
    This reply has been marked as private.
    #20933

    Scott Lang
    Keymaster
    This reply has been marked as private.
    #20934

    Scott Lang
    Keymaster
    This reply has been marked as private.
    #22563

    srinivas
    Participant
    Hello team, Not solved till now.   <span style="color: #505050; font-family: OpenSans, Helvetica, Arial, sans-serif; font-size: 12px; white-space: pre-wrap; background-color: #fafafa;">https://..../wp-json/wplms/v1/user/signin</span> POST { "code": "rest_forbidden", "message": "Sorry, you are not allowed to do that.", "data": { "status": 401 } }   please help
    #22565

    Scott Lang
    Keymaster
    It is just a minor .htaccess issue share your  admin credential with us in private  reply . Above given credential is not valid. We will configure your app at our end.   Also put this line in your .htaccess file at the end (.htaccess can be found in root of your site ): SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0 IF above does not works then please change the above line to : SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1
    #29477

    Harry
    Spectator
    Hey send your site credential in private reply.
    #29478

    Pulkit Poddar
    Participant
    This reply has been marked as private.
    #29493

    Harry
    Spectator
    Hey i am tested, it will work properly and the registration and login page both working properly. see this:http://bit.ly/2JFXInC
    #29500

    Pulkit Poddar
    Participant
    Hi, Can you please share the code with me which you added to make it work and also the location? Along with that can you share the links you used for sign up and sign in?
    #29503

    Harry
    Spectator
    Hey send your src file i will make changes
    #29506

    Pulkit Poddar
    Participant
    This reply has been marked as private.
    #29509

    Harry
    Spectator
    Hey check issue resolved: https://we.tl/t-Zba4M0cxBY
    #29516

    Pulkit Poddar
    Participant
    This reply has been marked as private.
Viewing 30 posts - 1 through 30 (of 35 total)
  • You must be logged in to reply to this topic.