WordPress LMS for Web and mobile Forums WPLMS Student App Free course, but in the App I can not access

Free course, but in the App I can not access

Back to course
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1319

    Mine-Class
    Participant
    Hi guys I have a question, I have a student account, which has 2 courses, one paid and the other free, I logged with this account, but I can not enter any course, just show me the button "Private" and "Free" But when you click, it does not do anything. What is this? https://prnt.sc/h4eiqt thanks!
    #1331

    admin
    Member
    Is you site on https ? If yes then : there might be some mod security on server that is not authenticating any call to server from app .

    It seems like the https in your site is stripping the authorization code(a required parameter while making call to server) which is sent in headers .

    Please check this source : https://GITHUB.COM/GESELLIX/KEEPASS-NODE/ISSUES/9

    and these relevant links : https://STACKOVERFLOW.COM/QUESTIONS/26549250/APACHE-STRIPS-DOWN-AUTHORIZATION-HEADER

    https://HTTPD.APACHE.ORG/DOCS/2.4/EN/MOD/CORE.HTML#CGIPASSAUTH

    You need to allow access for authorization to stop stripping of the authorization code from headers .

     

    Please contact your webhost on this .They would have to disable such mod security for this . More links to this : https://stackoverflow.com/QUESTIONS/26549250/APACHE-STRIPS-DOWN-AUTHORIZATION-HEADER

    https://stackoverflow.com/questions/9780966/where-do-i-put-wsgipassauthorization-on

    #1622

    Mine-Class
    Participant
    This reply has been marked as private.
    #1624

    Mine-Class
    Participant
    This reply has been marked as private.
    #1641

    admin
    Member
    Well its necessary to disable that mod_security if you want the api to work for your app . . For that you would need to add this line SecFilterEngine Off in your .htaccess file . and yes you need to put the correct url of your site with https in it coz your site is on https.
    #1686

    Mine-Class
    Participant
    This reply has been marked as private.
    #1693

    admin
    Member
    Please share your site url and admin credentials to check this issue at your end . PS : mark reply as private while sharing .
    #1712

    Mine-Class
    Participant
    This reply has been marked as private.
    #1724

    admin
    Member
    Well yes the issue is confirmed that server is stripping the authorization parameter in headers of each api call . Please show my reply to your webhost and ask them to resolve it as this is a server related issue  :  https://wplms.io/forums/topic/free-course-but-in-the-app-i-can-not-access/#post-1331.
    #1834

    Mine-Class
    Participant
    This reply has been marked as private.
    #1840

    admin
    Member
    There is some error appearing in api with price html . Please share your valid ftp credentials in private reply  to fix the issue .
    #1865

    Mine-Class
    Participant
    This reply has been marked as private.
    #1873

    admin
    Member
      Ok I have corrected that file . now courses should open fine at your end . Now we are developing multiple pricing options for wplms app along with apply for course and pmpro membership .Right now you will see just pricing options there but wont be able to purchase it . Multiple pricing option feature is still under development .
Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.