WordPress LMS for Web and mobile Forums WPLMS Student App Installing necessary packages- failed to fetch

Installing necessary packages- failed to fetch

Back to course
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #913

    Pavel Safonov
    Participant

    Hello

    I am stuck on Installin necessary packages step

    I always got error and failed to fetch for all packages

    I managed to complete
    npm install ng2–dragula dragula —save
    npm install videogular2 –save
    when I changed —save to ——save

    But with all other cases- I always got failed to fetch.

    Please refer to screenshots:

    #1126

    Pavel Safonov
    Participant

    any comments please?

    #1163

    Pavel Safonov
    Participant

    it is really strange to get such kind of support from wplms team…

    #1168

    Bait ALFatih
    Participant

    I got error in safari.. and cannot view in ionic view IOS application..
    Runtime Error
    Uncaught (in promise): undefined

    [email protected]://localhost:8100/build/polyfills.js:3:19141 [email protected]://localhost:8100/build/polyfills.js:3:18842 http://localhost:8100/build/polyfills.js:3:19614 [email protected]://localhost:8100/build/vendor.js:4239:43 [email protected]://localhost:8100/build/polyfills.js:3:10224 [email protected]://localhost:8100/build/polyfills.js:3:7281 [email protected][native code]

    #1169

    Pavel Safonov
    Participant

    10 days had passed and still no answer

    #1197

    Alex
    Keymaster

    Hi apologies for the late response ,

    @Pavel Safonov please try : cordova plugin add {plugin-name} –nofetch

    The cordova 7 uses the npm to install the plugins, and probably your npm is

    not globally installed, or misconfigured.


    @Bait
    ALFatih,
    the issue with the typescript error is fixed now in app update.Please download new ionic package from themeforest account .

    #1204

    Bait ALFatih
    Participant

    Alex,

    I have downloaded the latest version.

    and now i got error
    <span style=”color: #666666; font-family: -apple-system, Roboto, system-ui, ‘Segoe UI’, ‘Helvetica Neue’, sans-serif, ‘Apple Color Emoji’, ‘Segoe UI Emoji’, ‘Segoe UI Symbol’; font-size: 14px;”>Uncaught (in promise): TypeError: Cannot read property ‘length’ of null TypeError: Cannot read property ‘length’ of null at http://localhost:8100/build/main.js:1664:43 at t.invoke </span>

    And now i cannot log in with existing user id, the sign in button always open new browser for authentication.

    #1209

    WPLMS
    Keymaster

    Please check the following code in your ionic app :

     

    src/services/config.ts

    locate the variable : this.settings

    and check the following lines :

    registration’:’app’,//’app’ or ‘site’ or false

    ‘login’:’simple’,//Select from ‘simple’ or ‘site’ or false

     

    make sure the registration is set to app and login is set to simple.

     

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.