WordPress LMS for Web and mobile Forums Ionic App Support No content showing in app

No content showing in app

Viewing 30 posts - 1 through 30 (of 47 total)
  • Author
    Posts
  • #6829

    Sandi
    Participant
    Hi I need some help. I've followed the instructions in the course to set up an app but I can't get it connected. I can see the test data but when I change the url and client id in config.ts i only get a blank screen and "no courses found". I also don't see any Clients with WPLMS oAuth server. My site is on https.
    #6834

    admin
    Member
    did you enable the api from wp-admin -> lms -> settings -> api . refer : http://prntscr.com/iehg4t  Also check have you added correct client id in your app . check configuring app section in course :  https://wplms.io/course/getting-started-with-wplms-mobile-app/    If all is correct but still not able to see any content from your site then please provide us your site url and admin credentials in a private reply to check this .
    #6841

    Sandi
    Participant
    This reply has been marked as private.
    #6859

    admin
    Member
    Ok I checked your site and replicated the issue at first . I guess there is some kind of security in place that is blocking the requests from localhost to your server . I suspected it might be access control origin issue . SO I added an extension that fixes this .   This issue does not appears in app when you compile it but it does appears on browser when you are building and modifying your app .   To resolve this please add this extension in your browser : https://chrome.google.com/webstore/detail/allow-control-allow-origi/nlfbmbojpeacfghkpbjhddihlkkiljbi?hl=en
    #6869

    Sandi
    Participant
    Thanks Alex Seems to work fine now with the extension although I don't see any course content. All my content is in audio files streamed from S3. Does S3 work with the app?
    #6909

    admin
    Member
    Okay yes issue is replicated . Acutally s3 support for audios is not added in app api .I have added it now . This will be fixed in next update of app and vibe course module plugin . Thanks for reporting this.
    #6913

    Sandi
    Participant
    Hi Alex thanks for the info. Do you maybe have an aproximate release date for the update?
    #6979

    admin
    Member
    It might take some time . Please replace the "course-status.html" file in your " src/pages/course-status " folder with the "course-status.html" file that you will find in this attached course-status.zip file   : http://bit.ly/2Cukg3Z    and for vibe course module plugin Please replace the "class-api-user-controller.php" file in your site  " wp-content/plugins/vibe-course-module/includes/api/ " folder with the "class-api-user-controller.php" file that you will find in this attached class-api-user-controller.zip file  : http://bit.ly/2BC8Tdx  
    #6983

    Sandi
    Participant
    Hi Alex The first link isn't working. It's just redirecting me to homepage.
    #9433

    admin
    Member
    Im sorry here is the correct link : http://bit.ly/2Cukg3Z
    #9448

    Sandi
    Participant
    This reply has been marked as private.
    #9496

    admin
    Member
    Well you need to follow the exact same steps in order to make it work . Make sure that you replaced the correct files. About the customization ,well basic cost is $19 plus the amount depending upon your customization requirements . Please share the customization requirements first only then we can tell you the total cost .
    #9501

    Sandi
    Participant
    This reply has been marked as private.
    #9533

    admin
    Member
    1. Well talking of server , I can provide you the whole ionic project in zipped format so that you can generate your app from it in future .   2. units on s3 ,can you please share more details exaclty which content of what type on s3 ? Are you talking about videos ? 3. Well that might not play as shortcodes are not supported in app as of now .Only some wplms premium addons shortcodes are supported like from wplms s3 , video vibe etc . 4. sure 5. & 6. yes that can be done .   7. Well we have it but its incmoplete as courses does not expires as of now . We need make the courses as expired .  
    #9543

    Sandi
    Participant
    units are S3 audio, nothing else. I'll maka a workaround for the shortcodes. Do subscriptions maybe work with woocommerce subscriptions + memberships?
    #9562

    admin
    Member
    Yes s3 audios are now supported . If you are using wplms s3 plugin for your audio files in unit ,then they will work fine in wplms app .We do added support for this recently . Well subscriptions are not integrated in app right now . For woocommere subscriptions we need to add the support in the wplms api first . However wplms inbuilt subscriptions support will be added soon .As you may know that there is setting in course product settings to enable subscriptions . We will be adding support for that in app very soon . And for woocommerce memberships too .
    #9645

    Sandi
    Participant
    Hi Alex I'm still having trouble geting the S3 audio to work in the app and so does my developer team. Could you please check it one more time. I've followed your instruction, replaced the files exactly how you instructed but the audio still doesn't show in the app.
    #9658

    admin
    Member
    Did you replace the files as I told you to do in this reply : ? I tried to check it out but I do not have access to your wp-admin of your site ,credentials given previously are not working . Please share a valid admin credentials and a valid ftp credentials to check this issue . also share url of the course in which your audio units are present . PS : mark reply as private while sharing confidential information .
    #9667

    Sandi
    Participant
    This reply has been marked as private.
    #9681

    admin
    Member
    Ok I got the issue .the issue was appearing because you did not set the type of unit to be of "video" . You need to type of the unit to be video in order to parse the api that there is some media added to this unit .
    #9682

    admin
    Member
    set the type of the unit to be video . refer : http://prntscr.com/il92gx
    #9684

    Sandi
    Participant
    So I guess it still doesn't work. If I change to video it plays actually but in the video player, but I only have audio. The player then looks bad because it has blacked out video instead of being only an audio player.
    #9695

    guino
    Participant
    This reply has been marked as private.
    #9774

    admin
    Member
    Hi @sandibitenc-net,I forgot to share the scss file to you . Please replace the “course-status.scss” file in your ” src/pages/course-status ” folder with the “course-status.scss” file that you will find in this attached course-status.zip file  . download link : http://bit.ly/2D1R8kY     Hi @guino, Im sorry I could not find any issue with the my courses and profile page . I checked your units on your site and found that you are using shortcodes pdf-embedder .Note that shortcodes are not supported in app as of now  .We are currently working on it. I guess there is just pdf link appearing in your units . Please try adding some text to your units and check if that appears or not .
    #10368

    Sandi
    Participant
    Hi Alex As I've managed to get this working in chrome with the plugin for cross resource sharing. I've also managed to get it working for android but now I'm struggling with iOS. It's not showing any content as without the plugin in the browser (the same as when you tested it). Help?
    #10385

    admin
    Member
    Hi please try adding this line in your config.xml file for ios : <allow-navigation href="*"/>   refer : http://prntscr.com/iwf3fk
    #10387

    Sandi
    Participant
    No change. It's still not working. I've added the line to config.xml and made a new build but it still doesn't show in xcode or flight mode. I have attached the screenshot that shows the same build in chrome and xcode. xcode does not have any content. https://snag.gy/YH6lnz.jpg
    #10427

    admin
    Member
    Yup this is an issue with imagecache . We would need to remove the image cache tag from all over the app . Please share your src folder in zipped format ,I will remove all the imagecache tags and replace them with the img tags . This will show the images .
    #10455

    Sandi
    Participant
    This reply has been marked as private.
    #10476

    admin
    Member
    This reply has been marked as private.
Viewing 30 posts - 1 through 30 (of 47 total)
  • You must be logged in to reply to this topic.
ofis escort
paperio
istanbul Evden Eve Nakliyat istanbul Evden Eve Nakliyat
gaziantep escort
London Escorts

ankara escort bayan

Erken bosalma ve cinsel iktidarsizlik sorununu cozen kamagra oral jel icin sitemizden siparis verin

kamagra kapıda ödeme garantisi ve kamagra 100 mg kullanımına dair tüm bilgileri internet sayfamızdan bulabilirsiniz. Üstün bir cinsel hayat için en çok tercih edilen ürünlerden olan kamagra jel hakkında bilgi almak için ziyaret edin.