WordPress LMS for Web and mobile Forums Ionic App Support No content showing in app

No content showing in app

Viewing 17 posts - 31 through 47 (of 47 total)
  • Author
    Posts
  • #10488

    Sandi
    Participant
    Hi Alex I tried the files you sent me but no change. I still get everything working in the browser but when I try it on the emulated device or test it in TesFlight there's no content.
    #10500

    admin
    Member
    Ok i see that please try running this command and tell me what cordova plugins you are using ? cordova plugin list send the screenshot if the listed plugins . also try running this command in your ionic cordova project . cordova plugin rm cordova-plugin-ionic-webview
    #10569

    Sandi
    Participant
    Hmm. I've just made a backup of the whole site on another server and tried connecting the app to that one and it worked. So it seems there's an issue with the webserver. I think it's connected to the same problem that it displays only in chrome with the cross origin resource sharing. I've tried working with my hosting provider but they don't know what could be wrong. Do you have any idea what settings to check?
    #10604

    admin
    Member
    Well you can try using this solution on your webserver : https://stackoverflow.com/a/13871027  Also make sure that your config.xml contains this line : <access origin="*" />   Also make sure that these cordova plugins are added into your ionic project : cordova-plugin-camera 3.0.0 "Camera" cordova-plugin-console 1.1.0 "Console" cordova-plugin-device 1.1.4 "Device" cordova-plugin-facebook4 1.7.4 "Facebook Connect" cordova-plugin-file 5.0.0 "File" cordova-plugin-file-transfer 1.7.0 "File Transfer" cordova-plugin-googleplus 5.1.1 "Google SignIn" cordova-plugin-inappbrowser 1.7.2 "InAppBrowser" cordova-plugin-inapppurchase 1.1.0 "In App Purchase" cordova-plugin-ionic-webview 1.1.16 "cordova-plugin-ionic-webview" cordova-plugin-ios-non-exempt-encryption 1.0.0 "ITSAppUsesNonExemptEncryption false" cordova-plugin-splashscreen 4.0.3 "Splashscreen" cordova-plugin-statusbar 2.3.0 "StatusBar" cordova-plugin-whitelist 1.3.1 "Whitelist" cordova-sqlite-storage 2.0.4 "Cordova sqlite storage plugin"   ionic-plugin-keyboard 2.2.1 "Keyboard"     command to check installed plugins : cordova plugin list   command to add plugin : cordova plugin add cordova-plugin-{plugin_name} eg: cordova plugin add cordova-plugin-whitelist  
    #10630

    Sandi
    Participant
    Hi Alex thank you for your reply. I have all the plugins instaled. This is my list:

    cordova-plugin-camera 4.0.2 "Camera"

    cordova-plugin-console 1.1.0 "Console"

    cordova-plugin-device 2.0.1 "Device"

    cordova-plugin-facebook4 1.9.1 "Facebook Connect"

    cordova-plugin-file 6.0.1 "File"

    cordova-plugin-file-transfer 1.7.1 "File Transfer"

    cordova-plugin-googleplus 5.2.1 "Google SignIn"

    cordova-plugin-inappbrowser 2.0.2 "InAppBrowser"

    cordova-plugin-inapppurchase 1.1.0 "In App Purchase"

    cordova-plugin-ionic-webview 1.1.16 "cordova-plugin-ionic-webview"

    cordova-plugin-ios-non-exempt-encryption 1.0.0 "ITSAppUsesNonExemptEncryption false"

    cordova-plugin-splashscreen 5.0.2 "Splashscreen"

    cordova-plugin-statusbar 2.4.1 "StatusBar"

    cordova-plugin-whitelist 1.3.3 "Whitelist"

    cordova-sqlite-storage 2.3.0 "Cordova sqlite storage plugin"

    ionic-plugin-keyboard 2.2.1 "Keyboard"

    Still the app is not showing any content. It's not the lazy-img issue as I corrected that and the api key is correct as it is working if I test in browser. It's also working on android.
    #10631

    Sandi
    Participant
    I also tried this with no luck: https://stackoverflow.com/questions/33130559/cordova-plugin-whitelist-working-on-android-but-not-ios-phonegap-build
    #10641

    admin
    Member
    Well its this plugin that you have "cordova-plugin-ionic-webview " . This plugins should not be there in your wplms ionic project . It looks like this command was not executed well enough : cordova plugin rm cordova-plugin-ionic-webview   Please run the above command then re-run cordova plugin list to check installed modules . After removing that plugin please run this command : cordova prepare then generate app for ios and test it . As far as I know this was the issue with the project when I checked your src folder . Please try above recommended solution and I hope it will work this time .
    #10651

    Sandi
    Participant
    Tried it but no luck. Removed the webview and rebuild after your instructions. I even downgraded cordova ios to 4.4.0 to make cordova-console working. Nothing, removed it.. again nothing.
    #10659

    admin
    Member
    This reply has been marked as private.
    #10662

    Sandi
    Participant
    I got it to work just about the same time you send me the project files. I've added a few lines to config.xml and set the plugin versions to the same as yours and it started working. Also tested your build and it's also working. There is one more bug dough. Mp3 files from S3 aren't playing and that is either through the native <audio> tag or your S3 plugin. The native audio files are in the description of the course. The player shows but nothing's happening if I click on play. It's the same with S3 (though this one is going through course video S3 plugin) and is visible in units. Can I get some more help here? thank you
    #10663

    Sandi
    Participant
    Correction. The WPLMS S3 plugin plays the audio but does not stream it. If I wait about 10 seconds before I click on play it starts playing. If I click play before that then it wont play at all. It seems like the plugin downloads the whole file and is then able to play it. Another problem is that iOS thinks it's a video (the course setting has to be video as audio isn't supported yet) and because of that opens a fullscreen video player that is whole black and then even the UI hides and you only see a black empty screen. The native audio tag doesn't work at all.
    #10692

    admin
    Member
    Well we have fixed this but has not released any update for this . Please try replacing "course-status.html" and "course-status.scss" files in your ionic project folder -> src/pages/course-status folder with files given in this course-status.zip file : https://bit.ly/2GCGhAt    This will show the player as audio player . for the buffering issue well I guess this should be connected with internet speed and s3 bandwidth .
    #10742

    Sandi
    Participant
    Hi Alex Thank you for the updated code. I've managed to get it working although you forgot to change the <video> tag into <audio> tag. Also I have now all my units set to video (but using audio) as there was no other option to get it working. I also deployed the android app already so switching will be a bit of a pain... Well I'll think of something.
    #10743

    Sandi
    Participant
    This reply has been marked as private.
    #10771

    admin
    Member
    This reply has been marked as private.
    #10772

    admin
    Member
    This reply has been marked as private.
    #12205

    Compunet Limited
    Participant
    Hello @Sandibitencnet please which hosting provider are you using. I dont seem to have ANY headway with mine. And since i am not experienced with any of this i might need a pointer to which hosting is better. please
Viewing 17 posts - 31 through 47 (of 47 total)
  • You must be logged in to reply to this topic.

izmir escort

antalya escort

izmir escort

antalya escort

izmir escort

bursa escort

porno izle

porno izle

porno izle

escort istanbul

instagram ucuz takipçi satın al

takipçi hilesi

takipçi satın al

beğeni gönder

türk gerçek takipçi satın al

beğeni hilesi yap