WordPress LMS for Web and mobile Forums App Support Sites Content not loading in App

Sites Content not loading in App

Tagged: 

Viewing 30 posts - 1 through 30 (of 38 total)
  • Author
    Posts
  • #46049

    bandhe
    Participant

    Hello Team,

    The app is not showing any of the site’s courses in app.
    Its showing content when run using Ionic serve. But not showing courses when running debug apk in phone.
    the build was generated using “Ionic cordova build android –debug”.

    Also the html content takes long time to load like nearly 5 minutes.
    Initially the app itself was not loading, it showed error “Unable to load assets/index.html”. After searching the forum came across post to set timeout “<preference name=”loadUrlTimeoutValue” value=”700000″ />”. Which fixed the error, but takes long time to show the app content. Even after that the site specific courses dont load.

    #46125

    Harry
    Spectator
    This reply has been marked as private.
    #46173

    bandhe
    Participant
    This reply has been marked as private.
    #46326

    Scott Lang
    Keymaster
    This reply has been marked as private.
    #46346

    bandhe
    Participant

    hi. I have tried clearing the cache and data in app, still nothing. no content is loading.

    I’m adding the app link here kindly check https://drive.google.com/file/d/1FdUVGNuMSS7EmgBmLnWdtQjpzZyzxnt3/view?usp=sharing

    site content is displaying when previewing the app in pc but not loading when installing the app in android device

    #46608

    Scott Lang
    Keymaster

    At our site, your app is working perfectly But your given app is not working.

    Refer our config.xml:https://we.tl/t-IqU8FGGRcG

    #47504

    Harry
    Spectator
    This reply has been marked as private.
    #47530

    bandhe
    Participant

    Hi please re-share the link to package.json & config.xml file. The second link that you shared is same as the first one both points to the APK file.

    #47595

    Harry
    Spectator
    This reply has been marked as private.
    #47615

    bandhe
    Participant

    Again there is no link. Kindly attach the config.xml and the package.json

    #47717

    Harry
    Spectator

    Hello

    I have add in the above reply.

    #47734

    Dante
    Participant

    i cannot make reply

    #47840

    bandhe
    Participant

    hi when testing the app which you have build and shared it here, the profile page is not loading,only the avatar,email and name is showing, it shows loading but never shows any details. also the free units are not visible in courses in app

    #47998

    Harry
    Spectator

    Hello

    If you say then should i built the app for you?

    Because in my setup the app will be working fine.

    #48108

    Danilo
    Participant

    I have the same problem but with ios, the strange thing is that I have given all the files to help me and they only give me repetitive solutions, it happens to me the same as you do, the courses do not load me, you do not see anything, I leave you my post so you can see my case, it is really similar to yours, only the courses are displayed in google chrome but not in safari (with ionic serve) and when I generate the .ipa (in android it is .apk) you don’t see any courses Hopefully we can complement you and me because here they do not give any accurate help, I don’t know if the objective is for them to charge us to be able to solve what happens

    My case: https://wplms.io/forums/topic/app-does-not-work-on-ipad-iphone-safari-rejected-on-app-store/#post-44861

    #48181

    Scott Lang
    Keymaster

    Also put this line in your .htaccess file at the end (.htaccess can be found in root of your site ):
    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0
    IF above does not works then please change the above line to :
    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1

    #51427

    Malika Sharma
    Participant

    Hi,

    Same error I have, Please find my signed apk in this link. https://drive.google.com/file/d/12wDx64lkMvNvZFRAY0_7AN8_ZL0ea-3X/view?usp=sharing

    Please give me proper reply?

    #51502

    Harry
    Spectator

    Hello

    This will be the Finalized App so I can’t test with this App.

    so send a debug App for the testing purpose.

    Build the debug app with this command: ionic Cordova build android

    and send this generated App.

    #51547

    Malika Sharma
    Participant
    This reply has been marked as private.
    #51608

    Harry
    Spectator

    Hello

    I have tested in the  debug App, But the app data will be loading.

    See this video: https://bit.ly/2y3evhu

    #51650

    Malika Sharma
    Participant

    hello, please check the attachment..my app is not synchronizing the any website data …

    please resolve the issue.

    https://drive.google.com/file/d/1I5JsJ5w_jYwq0PYTZDXgGaZ5OwcYf4Eu/view?usp=sharing

    #51743

    Harry
    Spectator

    Hello

    I have already sent a video from there the site content will be loaded in the App.

    and also in the above credential will be different from your App see this https://prnt.sc/s7srd2

    so if you want then I am building the App for you.

    Also, send your working credential.

     

     

    #51770

    Malika Sharma
    Participant
    This reply has been marked as private.
    #51896

    Harry
    Spectator

    Hello

    If I am trying to check through my setup it will be working https://prnt.sc/s8evt5  Just it will take some time to fetch the API.

    so please check in your App and wait for 2-3 seconds the data will be fetched.

    So the problems not in the App this will be because of your hosting.

     

    #56913

    Raju IEXIST
    Participant

    Hi,

    I have created a debug apk file and installed it on my phone. The app is installed successfully and opened. But the courses are not showing in apk file. But when I run ‘ionic serve’ the courses are showing. I have given the URL and app id in config.ts file. But in apk the courses are not showing. The homepage is coming blank.

    I have created the apk using the command ‘ionic cordova build –debug android’  and also i tried to create from android studio. But both lead to the same issue.

    #56916

    Harry
    Spectator

    Hello

    Created the android app with this command
    ionic Cordova build android

    And after that check that, If it’s not working then share that apk with us, Then I am checking the issue.

     

    #56920

    Raju IEXIST
    Participant
    This reply has been marked as private.
    #57010

    Harry
    Spectator

    Hello

    When I am checking in my android device, See it will work perfectly:https://bit.ly/3hLpPRt

    so test it properly.

    #57023

    Raju IEXIST
    Participant
    This reply has been marked as private.
    #57123

    Raju IEXIST
    Participant
    This reply has been marked as private.
Viewing 30 posts - 1 through 30 (of 38 total)
  • You must be logged in to reply to this topic.