WordPress LMS and WP Education Theme for Academy and Education Institutes Forums App Support /wp-json/wplms/v1/course/category returns "rest_no_route"

/wp-json/wplms/v1/course/category returns "rest_no_route"

Tagged: ,

This topic contains 2 replies, has 2 voices, and was last updated by  Scott Lang 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #24245

    Kwang Hee Lee
    Participant

    (Continued from https://wplms.io/support/forums/topic/wp-json-wplms-v1-course-category-returns-rest_no_route/)

    Hi, I bought WPLMS theme and Ionic app.
    My Ionic app is not working because WordPress server returns “rest_no_route” when call some Rest API.
    For example, http://[my_server]/wp-json/wplms/v1/course/category returns json below.

    {“code”:”rest_no_route”,”message”:”URL\uacfc \uc694\uccad \ubc29\ubc95\uc774 \uc77c\uce58\ud558\ub294 \ub8e8\ud2b8\ub97c \ucc3e\uc744 \uc218 \uc5c6\uc2b5\ub2c8\ub2e4″,”data”:{“status”:404}}

    (But when I access API root path, it seems to work well. For example, http://[my_server]/wp-json/wplms/v1 returns json below.

    {“namespace”:”wplms\/v1″,”routes”:{“\/wplms\/v1”:{“namespace”:”wplms\/v1″,”methods”:[“GET”],”endpoints”:[{“methods”:[“GET”],”args”:{“namespace”:{“required”:false,”default”:”wplms\/v1″},”context”:{“required”:false,”default”:”view”}}}],”_links”:{“self”:”http:\/\/[my_server]\/wp-json\/wplms\/v1″}},”\/wplms\/v1\/reports\/top_competion_courses”:{“namespace”:”wplms\/v1″,”methods”:[“GET”],”endpoints”:[{“methods”:[“GET”],”args”:[]}],”_links”:{“self”:”http:\/\/[my_server]/wp-json\/wplms\/v1\/reports\/top_competion_courses”}},”\/wplms\/v1\/reports\/top_learner_completions”:{“namespace”:”wplms\/v1″,”methods”:[“GET”],”endpoints”:[{“methods”:[“GET”],”args”:[]}],”_links”:{“self”:”http:\/\/[my_server]\/wp-json\/wplms\/v1\/reports\/top_learner_completions”}}},”_links”:{“up”:[{“href”:”http:\/\/[my_server]\/wp-json\/”}]}}

    Is there I missed things? How can I fix it?

    And I didn’t customize my app.

    #24690

    Scott Lang
    Keymaster

    Hi,

    Make sure you vibe-course-module plugin is updated.

    #24691

    Scott Lang
    Keymaster

    Also you can use postman to make api hit to get response.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Template Design © VibeThemes. All rights reserved.