Quizzes on react

In wplms 3.9.7 we have migrated our quizzes to react framework.

Now wplms quizzes are faster, better ,touch support .

 

IMPORTANT NOTES :

1 . IN order this to work please enable Api from wp-admin ->LMS-> settings -> Api .

2. You would need to update vibe course module , vibe customtypes and wplms theme to version 3.9.7 

3 . you might also need to add this line in your.htaccess file :

SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0

If above line does not work please change the above line to :

SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1

4. the setting ” In-Course Quiz questions per page ” will play no role in as there is new setting given in the quiz to set number of questions.Read below .

 

 

To start with All you need is to enable ” Enable React Quizzes ” from wp-admin -> lms -> settings :

This will enable a setting in each quiz to set number of questions to load on single as well as in in-course quiz :

the questions will load according to this setting in quiz .

 

 

Was this article helpful?

Related Articles

16 Comments

  1. zatakk

    Hi
    Some quizzes are showing properly. Some not at all. Some the timer clock is not showing. I made changes to .HTACCESS. But no effect at 0 or 1.

    What to do ?

    1. Diana

      We are moving wplms modules on reacts which is much better then using queries. It shifts loads from server and hence faster. If you are facing any issue then we can check the issue on your site. Please create a topic in the forum and our team will assist you there

  2. Max

    Hi, my quizzes are not working after enabling React Quizzes!
    I made changes to .HTACCESS. But no effect at 0 or 1.

  3. jango

    how will we know that we have shifted to Quizzes on react after doing all the steps you mentioned?

  4. eshikhon

    HUGE BUG!
    Hellow, I have updated themes and all plugins
    but still I did not see “Correct Answer:” after submitting and checking quiz results.
    It only Show Marked Answer:
    but Correct Answer showing None.
    check the screenshot: http://prntscr.com/q5a3yb

    1. Alex

      Try disabling “hide correct answers” setting from wp-admin -> lms -> settings .

  5. Aminul

    I have added this SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0 on the htaccess file. but wpengin told me that “You need to contact the plugin developer on this please as we do not assist with plugin issues unfortunately. You can never use GETenv or SETenv on wpengine. ”

    What is the solution for that?

    1. VibeThemes

      For WP Engine you need to use : SetEnvIf Authorization “(.*)” HTTP_AUTHORIZATION=$1

      1. Aminul

        Where? The support of wpengin told me they are not permitted to add SetEnvIf on htaccess file. Which was I already told you on my last comment. Please give me the proper solution.

  6. shynkaryk

    There is a lot of bugs in this version of theme, unfortunately.

  7. Hello,

    For the fifth time I try to use your theme, always hoping that all bugs are resolved, but there are more and more.

    Worse, unlike other producers, you present the bugs (so you know they exist) and then present solutions that don’t work !!!

    They make people waste time for nothing. I even had 3 programmers to fix all your bugs, and when we have everything working, after a lot of work, I fall into the blunder of believing that the new versions do have what they present … Stop making others lose time , decrease features and integrations but do something that works !!!

    Your themes or plugins NEVER AGAIN !!!

  8. jackal

    Hi! It is fast but it doesn’t look the same as the default one. I want to have the same display (control buttons at the bottom) so it becomes compatible with default course status view. One more thing is that questions with T/F are not evaluating correctly. I set a question to 0, the student answered with 1 (which is wrong answer) and even so the question was auto evaluated as correct?
    I have been fixing a lot on the theme and its plugins and I’m joining many other here; please stop adding features and options, focus on fixing and enhancing the current ones. You already have hundreds of options and features with many bugs and shortages.

    Kind Regards,

  9. Sandeepbishnoi

    Hello hello sir, I have the same problem when I question further, then I have a problem but only keeps loading, it is not working, please solve my problem. Thank you.

  10. makarand

    I am running LMS on nginx, what to add in config file. in place of below
    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1

  11. roberta_denoia15

    quiz is not loading! Please, help!

    1 . IN order this to work please enable Api from wp-admin ->LMS-> settings -> Api .

    done

    You would need to update vibe course module , vibe customtypes and wplms theme to version 3.9.7

    it is 3.9.8

    3 . you might also need to add this line in your.htaccess file :

    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$0

    If above line does not work please change the above line to :

    SetEnvIf Authorization .+ HTTP_AUTHORIZATION=$1

    added the first line to .HTACCESS

    the setting ” In-Course Quiz questions per page ” will play no role in as there is new setting given in the quiz to set number of questions.Read below .

    I don’t understand the last point and I don’t kwow how to solve this problem.

    Please, help! Thank you

Leave a Reply to Aminul × Cancel Reply