DeliveredApp Errors

Tagged: 

Back to course
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1149

    mornetester
    Participant
    Good day guys, I have successfully able to compile app (debug and release versions) via ionic pro. APK generated successfully, able to install to my phone without any problem. Splash intro works great, courses show perfectly inside the app. All the public features inside work great, searching viewing courses etc works great. Problem starts when going to the user, login as user works perfectly, but from there nothing seems to work. At the profile screen after logging in it does NOT show the menu for accessing the courses, settings etc. The only thing that works is that I am able to change the profile photo. Not able to access any profile menu to access courses etc. Please advise... (I have purchased license for APP and WPLMS) Screenshots are of app connected to dev site with fresh install of wplms https://www.edubit.co.za/appscreenshots/Screenshot_2017-10-12-08-10-20.png https://www.edubit.co.za/appscreenshots/Screenshot_2017-10-12-08-10-20.png
    #1150

    SmithTips
    Participant
    Hi mornetester, I have done the installation myself and got stuck at this point with this error message: Runtime Error Uncaught (in Promise): undefined ... Please find attached for full details below: file:///C:/Users/Beny/Dropbox/Screenshots/Screenshot%202017-10-12%2006.58.38.png Did you face this challenge and how did you overcome it?
    #1152

    mornetester
    Participant
    I also got that error initially, took 3 days of trial and error to try get it to work. I uninstalled everything (ionic, npm cordova etc) and then reinstalled step by step again, and used latest versions of everything, then it worked. So not really sure what fixed it in the end.
    #1160

    mornetester
    Participant
    Hey team WPLMS, I have managed to get this great app to work on my dev site without SSL Everything so far works perfectly i am able to subscribe to course and then do the course all on the app. So far so good with the testing. Now problem comes when I recompile the app to use my dev site WITH SSL. Now after login on app nothing on the profile works, not seeing profile menu, not able to subscribe to course. Please advise fix for the app to use SSL site then I am sure you will get lots of app sales :) Please advise soonest. Kind Regards Morne
    #1212

    WPLMS
    Keymaster
    Please check if the authentication headers are not stripped by HTTPS. For this, run your app in debug mode or in browser mode, check the profile call to your server and make sure Authorisation headers are included as they send the token which is used for all kind of user validations in WPLMS.    
    #1226

    admin
    Member
    Hi, I debugged the issue with the api call at your end . It seems like the https in your site is stripping the authorization code which is sent in headers . this happens due to server mod securities and all . Please check this source : HTTPS://GITHUB.COM/GESELLIX/KEEPASS-NODE/ISSUES/9   and these relevant links : HTTPS://STACKOVERFLOW.COM/QUESTIONS/26549250/APACHE-STRIPS-DOWN-AUTHORIZATION-HEADER   HTTPS://HTTPD.APACHE.ORG/DOCS/2.4/EN/MOD/CORE.HTML#CGIPASSAUTH   You need to allow access for authorization to stop stripping of the authorization code from headers .
    #1239

    mornetester
    Participant
    Thanks guys working now on android version to SSL site :) htaccess rule added worked like a charm. Have successfully compiled and published beta version to google playstore without a hitch :) Will try IOS version later this month :)
    #1246

    admin
    Member
    That's Great :)  !!
Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘DeliveredApp Errors’ is closed to new replies.