WordPress LMS for Web and mobile Forums Ionic App Support Issue with –type=angular

Issue with –type=angular

  • This topic has 4 replies, 3 voices, and was last updated 1 year ago by Dante.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #59514

    Dante
    Participant
    Previously I compiled the app source with --type=ionic-angular But this method is for ionic 3 with angular 5 based on official IONIC Documentation . So as I need to make my app faster I need ionic 4 with --type=angular But shows error: C:\Users\ASRGURU\Desktop\ion\interlan>ionic info [ERROR] Error loading @ionic/angular package.json: Error: Cannot find module '@ionic/angular/package' Require stack: - C:\Users\ASRGURU\Desktop\ion\interlan\node_modules\ionic\lib\project\index.js - C:\Users\ASRGURU\Desktop\ion\interlan\node_modules\ionic\lib\index.js - C:\Users\ASRGURU\Desktop\ion\interlan\node_modules\ionic\index.js - C:\Users\ASRGURU\AppData\Roaming\npm\node_modules\ionic\bin\ionic my ionic Info Ionic: Ionic CLI : 5.4.16 Ionic Framework : not installed @angular-devkit/build-angular : 0.1000.3 @angular-devkit/schematics : 10.0.3 @angular/cli : 10.0.3 @ionic/angular-toolkit : 2.2.0
    #59552

    Harry
    Spectator
    Hello This is my ionic info:https://prnt.sc/tjjp8u You should download all the dependencies with this.
    #59562

    Dante
    Participant
    Hi harry as your ionic info shows you are created app project with --type=ionic-angular NOT --type=angular is it possible to create with second type I mean -- type=angular the way you are created is Ok for me but my purpose is to boast speed with ionic 4 type. If you confirm me the only way is to use flag: --type=ionic-angular so my question is done!
    #60287

    Scott Lang
    Keymaster
    Hi, Currently our app is worked on ionic V-3. V-4 is way different than V-3 as coding perspective.So we suggest you not to update your app currently otherwise you can get errors. Also the first command to create ionic app :https://gist.github.com/shubham-99fusion/d8c5d60ab3f3a0bcc1aa5102fee369c0 is just to initialize app.
    #60314

    Dante
    Participant
    very clear answer will there be a new version soon? or the next is going to be React native?
Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.